Подсветка синтаксиса

Syrnik.com

Задумал по-быстрому заделать бесплатный плагин для блога, чтоб код раскрашивать, обнаружил забавную вещь. У готовых решений либо нет поддержки Smarty, либо они требуют вкладывать code внутрь pre (примерно так: <pre><code> .... </code></pre>) а это не нравится redactor'у — он эскейпит все внутри <pre>.

Чуть-ли ни единственный — старый монстр GeSHI, у которого проблемы с юникодом. :)

Свой лексер написать можно, но тогда плагин бесплатным не получится. :)

13 июля 2015
  • wa-content/js/prettify/ не подходит? Или я не уловил суть проблемы?

  • Syrnik.com 13 июля 2015 05:24

    Суть проблемы верно определена, искать внутри движка мне в голову не пришло :) Посмотрю, что там и как и вечером на проверку отправлю

    P.S. Как же я про prettify забыл-то?



Чтобы добавить комментарий, зарегистрируйтесь или войдите