Версия PHP

Syrnik.com

Вот, например, о чем можно было бы поговорить.

Требование обязательной совместимости с PHP 5.2 напрягает время от времени. Инсталлер же умеет проверять версию. Давайте уже принимать в магазин плагины/приложения для 5.3+ и 5.4+ хотя бы.

Не то, чтобы мне очень были нужны short array syntax или traitrs/namespaces, но некоторые вещи разумнее реализовывать с использованием сторонних библиотек, которые уже 5.3+ или 5.4+ совместимы.

10 июля 2015
  • Укажите в системных требованиях:

    'php' => array(
        'strict' => true,
        'version' => '>=5.3',
    ),

    и напишите об этом ограничении жирным шрифтом в описании продукта. Вроде бы этого должно быть достаточно: и инсталлер, и пользователи предупреждены.

  • Syrnik.com 10 июля 2015 09:56

    Про системные требования я знаю.

    В прошлый раз, когда я спрашивал об этом, мне ответили, что для размещения в магазине приложение или плагин обязаны поддерживать минимальные требования, в том числе и 5.2 совместимость.

    Что-то меняется? :))

  • Вы спрашивали именно о возможности указывать версию PHP в системных требованиях плагина? Или вообще о возможности публиковать плагины только для PHP 5.3+, игнорируя возможные ошибки, которые могут появиться у тех, кто пользуется PHP5.3-?

  • Syrnik.com 10 июля 2015 10:03

    Я имел в виду «примут ли к размещению в каталоге приложений (плагинов) приложение или плагин, у которого в requirements.php будет указано 'php' => array('version' => '>=5.3')?»

  • Если придираться к этому ответу vofka, то надо признать, что он не не дал конкретного ответа ("да/нет") на ваш вопрос, особенно учитывая ваше замечание в самом начале, что вы уже знакомы с системными требованиями Вебасиста. Можно подождать более конкретного ответа на этот раз. Я слышал каким-то краем уха, что предложенный мной вариант вполне легитимен. Но я не могу отвечать официально по такому вопросу, т. к. он не в моей компетенции.

  • Syrnik.com 10 июля 2015 10:15

    Я не настаиваю на немедленном ответе. :) Но если есть возможность узнать точнее, узнай, pls. :)

    Я ответ voffka понял достаточно однозначно «…должно соответствовать базовым системным требованиям» — чего уж тут неясного? :)

  • Syrnik.com 10 июля 2015 10:16

    …в этой разделе редактирование запрещено... следует читать: «узнайте, pls» :)

  • Игорь 28 июля 2015 10:07

    у меня стоит на win сервере последняя версия php

    все работает без проблем..

  • Сергей, мы бы с удовольствием подняли бы требование на минимальную версию PHP, но быстро (прямо сейчас) сделать это не можем, так как пока еще есть довольно значимая часть пользователей фреймворка Webasyst на версии PHP 5.2.

    С будущими крупными обновлениями фреймворка требования на версию PHP будут неизбежно подниматься. Пока ничего не говорю о сроках, но, поверьте, необходимость в этом да и желание есть.

    В рамках текущих же обновлений мы должны сохранить совместимость с PHP 5.2, чтобы у конечных пользователей не возникало проблем с установкой обновлений и дополнений из магазина Webasyst. Поэтому к публикации в магазине пока принимаем только продукты, поддерживающие PHP 5.2.

  • Arti 13 августа 2015 10:53

    5.2.17 Released: 06 January 2011

    6 лет, Карл!

  • Syrnik.com 13 августа 2015 11:27

    Я так понимаю, что дело в годах, а в распространенности версии.

    Хотя по крайней мере те, кто использует скрипт для e-commerce вполне могли бы себе позволить не самый дешевый хостинг с современной версией.

    У меня есть смутные подозрения, что должна где-то уже разрабатываться версия фреймворка 2.0 и приложения к ней, причем возможно, несовместимая с 1.xx версией и ее приложениями. :)

    Надеюсь она будет PHP 7 only (хотя вряд ли )

  • Syrnik.com 14 сентября 2015 04:51

    Опять нудеть про версию буду.

    Обратил внимание, что многие пользователи видят требование "минимум 5.2" и думают, что лучше всего 5.2, даже если есть выбор более свежей версии.

    При этом на многих хостингах админы уже забили на работоспособность 5.2 и 5.3. И если вылезает ошибка, просто говорят, чтоб пользователь изспользовал более свежую версию.

    Вот тут у одного клиента достаточно большое количество времени пришлось потратить из-за того, что PHP не могло библиотеку найти. Весь серверный лог ошибок был завален:


    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/php52/lib/php/20060613//usr/local/php52/lib/php/20060613/simplexml.so' - Cannot open "/usr/local/php52/lib/php/20060613//usr/local/php52/lib/php/20060613/simplexml.so" in Unknown on line 0

    Саппорт хостинга порекомендавал перейти на версию PHP по-свежее. То есть админам даже путь было лень править.

    Ну, может, написать для разработчиков отдельно, что пространства имен не использовать, еще какие-то ограничения. Но в документации и при установке уже обозначить требование более свежей версии?

    Пока есть текущее требование минимальной версии, никто не же почешется у себя интерпретатор обновить, а пока не обновят — будут продолжаться рассказы о том, что на многих хостингах все еще...

  • Михаил Морозов (welldi) 14 сентября 2015 05:52

    Учитывая, что поддержка версии php 5.3 завершена 28 августа 2014 года (с момента выхода 5.6) и % соотношение версий на хостингах - думаю миграция неизбежна. Вопрос в том, что переход местами нетривиальный конечно, но кому в нашей жизни легко?

  • Syrnik.com 14 ноября 2015 12:28

    А я опять на вентилятор наброшу. :)

    Вот свежий случай.

    У пользователя плагина 5.2.13 на сервере. Вплоть до 5.2.14 во многих (если не во всех) сборках PHP был баг — забыли реализовать описанный в документации метод SimpleXML::__toString(). И что, теперь надо везде проверять и реализовывать обход этого бага? :-/

    Ладно, мы поняли про требования к размещению.

    Хотя бы пользователям в документации напишите что нужен 5.4+, а от разрабочиков продолжайте требовать 5.2-compatibility. Те кто ставит, они же не видят слова "минимальная версия". Они видят 5.2 и требуют от хостера именно 5.2. Конечно, хостер уже давно забил на обновление этой старой версии, но для клиента что-нибудь придумает...

    Самый прикол в том, что эта самая 5.2.13 установлена на... cz.webasyst.net (facepalm.jpg)

    И да. С кого бы денег взять за изучение истории фикса багов от версии к версии? :)

  • Алексей Webasyst 14 ноября 2015 12:51

    http://w3techs.com/technologies/details/pl-php/5/a...

    Version 5.3	36.3%
    Version 5.4	31.1%
    Version 5.5	14.1%
    Version 5.2	13.5%
    Version 5.6	4.1%
    Version 5.1	0.9%
    Version 5.0	less than 0.1%
    Version 5.7	less than 0.1%
    
    Сергей, вы учитывайте, что далеко не все на хостинге используют Shop-script 5/6. Кто-то например использует позапрошлую версию, где ни разу не устанавливалось обновление и там поддержки 5.3 еще не было.

    Хотя насчет поднятия требований согласен.

  • Syrnik.com 14 ноября 2015 13:01

    Поставьте у себя хотя бы 5.2.17 тогда. Там конечно все ще остались штуки типа CVE-2011-2202 но все же посвежее версия-то. Хоть SimpleXML рабочий (вроде бы)

  • Syrnik.com 14 ноября 2015 13:41

    Добавил в файл requirements.php строчку

    'php' => array( 'version' => '5.2.14', 'strict'=>true)

    Не знаю, пропустят-ли обновление с такими требованиями.

  • Denis - 5 декабря 2015 01:31

    Ставим shop script на хостинге можно выбрать версию php, какую лучше выбирать для новой установки и чтобы все сразу работало без сбоев?

  • Syrnik.com 5 декабря 2015 07:50

    PHP7. Если нет, то 5.6. Если нет, то 5.5. Если нет, то 5.4

  • Denis - 5 декабря 2015 09:44

    А что в сборке выбирать для php 5.6? В php 5.2 там много модулей и т/д галочки стоят по умолчанию, а тут как-то пусто.



Чтобы добавить комментарий, зарегистрируйтесь или войдите