Ошибка установки при проверки версии php.version, если ... Принято

1

Если пакет php установлен таким образом, где наименовании версии php.version = 7.4.3-4ubuntu2.16

Лучше сделайте проверку по PHP_VERSION_ID

2 комментария

  • +1
    creativit.ru creativit.ru 22 января 2023 21:07 #

    либо у вас вот это https://support.webasyst.ru/fo...

    • +1
      ▀ Сквёрд  ▀ Сквёрд  23 января 2023 05:22 #

      И это тоже может случится. Но у меня вот это :

      Требуется версия PHP >= 7.2.4 Текущая версия 7.4.3-4ubuntu2.16


      Если по PHP_VERSION_ID сравнивать и распарсить его правильно, то ошибки нет.

      По аналогии с Composer. У них там именно по PHP_VERSION_ID Сравнение а не по строковому параметру.

      Было бы: 70403 >= 70204

      Добавить комментарий

      Чтобы добавить комментарий, зарегистрируйтесь или войдите