Лицензия для shop-script 7 при локальной разработке?

Я поднял движок локально. Через некоторое время выплыло сообщение о лицензии. Но ведь я не могу заработать, когда сайт поднят локально, а не выложен в интернет. Так зачем просить лицензию в таком случае?

1 ответ

  • 1
    Павел Трофимов 31 мая 2018 01:15 #

    Берите из github и будет вам счастье

    • +1
      dagman dagman 2 июня 2018 03:40 #

      ну ok, взял из gihtub. Поднял, всё норм...хотя...секундочку...а что это у нас здесь) не хватает приложения "Магазин", кто бы мог подумать. Смотрю в /wa-config/apps.php, а там

      <?php
      
      return array(
          'contacts' => true,
          'site' => true,
          'blog' => true,
          'photos' => true,
      );

      изменил чуток - теперь

      <?php
      
      return array(
          'contacts' => true,
          'site' => true,
          'blog' => true,
          'photos' => true,
          'shop' => true,
          'team' => true,
      );
      

      Интересно, что приложение "Контакты" появилось и работает, а приложения "Магазин" как не было, так и нет.

      И я теперь думаю, ну ok, предположим, я каким-то образом подтяну приложение "Магазин". Вопрос ведь заключался в том, есть ли возможность получать обновления для этого приложения бесплатно, если ты что-то делаешь локально. Допустим, я хочу создать болванку на основе стандартной темы приложения "Магазин" и обновлять болванку по мере появления обновлений для стандартной темы. Однако если github версия не содержит этого приложения, соответственно не будет и обновлений для него.

        • +1
          dagman dagman 2 июня 2018 17:10 #

          спасибо) совсем другое дело)

        • +1
          dagman dagman 3 июня 2018 00:34 #

          Получил приглашение на приватный репозиторий, принял его. Делаю по инструкции

          git clone git://github.com/webasyst/shop-script.git ./

          получаю...

          dagman@DESKTOP-T78L6BG MINGW64 /e/ospanel/domains/webasyst.test/wa-apps/shop (master)
          $ git clone git://github.com/webasyst/shop-script.git ./
          Cloning into '.'...
          fatal: remote error:
            Repository not found.

          Попробовал как написано здесь

          git clone git@github.com:webasyst/shop-script.git ./

          получаю...

          dagman@DESKTOP-T78L6BG MINGW64 /e/ospanel/domains/webasyst.test/wa-apps/shop (master)
          $ git clone git@github.com:webasyst/shop-script.git ./
          Cloning into '.'...
          git@github.com: Permission denied (publickey).
          fatal: Could not read from remote repository.
          
          Please make sure you have the correct access rights
          and the repository exists.

          Подскажите, что не так?

        • +1
          dagman dagman 3 июня 2018 19:38 #

          ну так что делать?

          • 0
            Koin Koin 4 июня 2018 11:10 #

            Привет, попробуйте заменить,

            $ git clone https://github.com/webasyst/shop-script.git ./

          • 0
            EnsoStudio EnsoStudio 9 июня 2018 21:03 #

            зайти на гитхаб, скачать нужный дистрибутив и распаковать в папку с приложениями, переименовать в shop. как работать с гитхаб подскажет гугл.

Добавить ответ

Чтобы добавить комментарий, зарегистрируйтесь или войдите