Инсталлер проверяет requirements.php? Не принято

3

У меня есть подозрение, что при каких-то условиях, Инсталлер не проверяет возможность установки.

У меня есть клиент, который утверждает, что с помощью Инсталлера установил обновление несмотря на то, что у него на хосте установлена PHP 5.4, а обновленная версия плагина требует минимум PHP 5.6

Тут нужно как-то совместно с Вебассист эту ситуацию проверить. Если есть возможность, посмотреть, что там Инсталлер запрашивал, хэши, то-сё

5 комментариев

  • +2
    Михаил Ушенин Михаил Ушенин Webasyst 13 марта 2017 09:55 #

    Кажется, тут не хватает оператора сравнения:

        'php'           => array(
            'version' => '5.6.0',
            'Поддержка совместимости со старыми версиями PHP 5.2-5.5 отключена. Совместимость с PHP 5.6 будет поддерживаться до декабря 2017',
            'strict' => true
        ),

    Судя по документации, должно быть так:

        'php'           => array(
            'version' => '>=5.6.0',    //добавлен оператор сравнения >=
            'Поддержка совместимости со старыми версиями PHP 5.2-5.5 отключена. Совместимость с PHP 5.6 будет поддерживаться до декабря 2017',
            'strict' => true
        ),
    • +1
      Syrnik.com Syrnik.com 18 мая 2017 11:42 #

      Сделал как требуется

      'php'                    => array(
              'version'     => '>=5.6.0',
              'description' => 'Поддержка совместимости со старыми версиями PHP 5.2-5.5 отключена. Совместимость с PHP 5.6 будет поддерживаться до декабря 2017',
              'strict'      => true
          ),
      

      Вот вчера клиент через Инсталлер поставил плагин на систему с 5.3. Не понимаю, как это получилось

    • +1
      Михаил Ушенин Михаил Ушенин Webasyst 10 марта 2017 18:09 #

      Нужны более конкретные данные. О каком продукте идёт речь? Как у этого продукта выглядит содержимое файла requirements.php?

    • +1
      Syrnik.com Syrnik.com 10 марта 2017 20:02 #

      Продукт https://www.webasyst.ru/store/plugin/shop/sdekint/

      Хост клиента мне не хотелось бы в общий доступ выкладывать :)

      requirements.php

      return array(
          'php'           => array(
              'version' => '5.6.0',
              'Поддержка совместимости со старыми версиями PHP 5.2-5.5 отключена. Совместимость с PHP 5.6 будет поддерживаться до декабря 2017',
              'strict' => true
          ),
          'php.curl'      => array(),
          'phpini.allow_url_fopen' => array(),
          'php.mbstring'  => array(
              'description' => 'Сравнение Unicode строк', 'strict' => true,
          ),
          'php.simplexml' => array(
              'description' => 'Обработка запросов и ответов удаленного сервера', 'strict' => true,
          ),
          'app.shop'      => array(
              'version' => '7.2.1',
              'strict'  => true
          ),
          /**
           * - waNet class requires Webasyst Framework 1.5.7+
           * - Models have a new truncate() method since WAF 1.6.0
           */
          'app.installer' => array(
              'version' => '1.6.0', 'strict' => true,
          ),
      );
      
    • +1
      Syrnik.com Syrnik.com 10 марта 2017 20:06 #

      Или я там description пропустил.... Хотя, судя по коду, не должно влиять

      Добавить комментарий

      Чтобы добавить комментарий, зарегистрируйтесь или войдите